<!DOCTYPE html>
<!--[if IE 6]>
<html id="ie6"  lang="en-US">
   <![endif]-->
<!--[if IE 7]>
   <html id="ie7" lang="en-US">
      <![endif]-->
<!--[if IE 8]>
      <html id="ie8" lang="en-US">
         <![endif]-->
<!--[if !(IE 6) | !(IE 7) | !(IE 8)  ]>
         <html lang="en-US">
            <![endif]-->
            
<html>
    <head>
        <meta charset="UTF-8" />
        <meta name="Theme Version" content="3.1" />
        <meta name="Child Theme" content="false" />
        <meta name="viewport" content="width=device-width, initial-scale=1.0, minimum-scale=1.0, maximum-scale=1.0, user-scalable=0" />
<meta name="google-site-verification" content="rX2k4XZXH4gf5zeVHDrN9F0MTRM9ptCsKmF7VVDUBvY" />
        <title>
            WGCA 88.5fm  | I&#8217;m Going To Fight For You        </title>
                  <link rel="shortcut icon" href="http://www.wgca.org/wp-content/uploads/2013/12/favicon.png"  />
                                                <link rel="alternate" type="application/rss+xml" title="WGCA 88.5fm RSS Feed" href="http://www.wgca.org/feed/">
        <link rel="alternate" type="application/atom+xml" title="WGCA 88.5fm Atom Feed" href="http://www.wgca.org/feed/atom/">
        <link rel="pingback" href="http://www.wgca.org/xmlrpc.php">
         <!--[if lt IE 9]>
         <script src="http://www.wgca.org/wp-content/themes/jupiter/js/html5shiv.js" type="text/javascript"></script>
         <![endif]-->
         <!--[if IE 7 ]>
               <link href="http://www.wgca.org/wp-content/themes/jupiter/stylesheet/css/ie7.css" media="screen" rel="stylesheet" type="text/css" />
               <![endif]-->
         <!--[if IE 8 ]>
               <link href="http://www.wgca.org/wp-content/themes/jupiter/stylesheet/css/ie8.css" media="screen" rel="stylesheet" type="text/css" />
         <![endif]-->

                  <script type="text/javascript">
         var mk_header_parallax, mk_responsive_nav_width, mk_header_sticky, mk_header_parallax, mk_banner_parallax, mk_page_parallax, mk_footer_parallax, mk_body_parallax;
          mk_images_dir = "http://www.wgca.org/wp-content/themes/jupiter/images",
          mk_theme_js_path = "http://www.wgca.org/wp-content/themes/jupiter/js",
          mk_responsive_nav_width = 1140,
          mk_smooth_scroll = true,
          mk_header_sticky = true;
                    mk_header_parallax = false,
          mk_banner_parallax = false,
          mk_page_parallax = false,
          mk_footer_parallax = false,
          mk_body_parallax = false,
          mk_no_more_posts = "No More Posts";
                   </script>
    <script type='text/javascript'>SG_POPUPS_QUEUE = [];SG_POPUP_DATA = [];SG_APP_POPUP_URL = 'http://www.wgca.org/wp-content/plugins/popup-builder';SG_POPUP_VERSION='2.42_1'</script><link rel="alternate" type="application/rss+xml" title="WGCA 88.5fm &raquo; Feed" href="http://www.wgca.org/feed/" />
<link rel="alternate" type="application/rss+xml" title="WGCA 88.5fm &raquo; Comments Feed" href="http://www.wgca.org/comments/feed/" />
<link rel="alternate" type="text/calendar" title="WGCA 88.5fm &raquo; iCal Feed" href="http://www.wgca.org/events/?ical=1" />
<link rel="alternate" type="application/rss+xml" title="WGCA 88.5fm &raquo; I&#8217;m Going To Fight For You Comments Feed" href="http://www.wgca.org/blog/im-going-to-fight-for-you/feed/" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/72x72\/","ext":".png","source":{"concatemoji":"http:\/\/www.wgca.org\/wp-includes\/js\/wp-emoji-release.min.js"}};
			!function(a,b,c){function d(a){var c,d,e,f=b.createElement("canvas"),g=f.getContext&&f.getContext("2d"),h=String.fromCharCode;return g&&g.fillText?(g.textBaseline="top",g.font="600 32px Arial","flag"===a?(g.fillText(h(55356,56806,55356,56826),0,0),f.toDataURL().length>3e3):"diversity"===a?(g.fillText(h(55356,57221),0,0),c=g.getImageData(16,16,1,1).data,g.fillText(h(55356,57221,55356,57343),0,0),c=g.getImageData(16,16,1,1).data,e=c[0]+","+c[1]+","+c[2]+","+c[3],d!==e):("simple"===a?g.fillText(h(55357,56835),0,0):g.fillText(h(55356,57135),0,0),0!==g.getImageData(16,16,1,1).data[0])):!1}function e(a){var c=b.createElement("script");c.src=a,c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var f,g;c.supports={simple:d("simple"),flag:d("flag"),unicode8:d("unicode8"),diversity:d("diversity")},c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.simple&&c.supports.flag&&c.supports.unicode8&&c.supports.diversity||(g=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",g,!1),a.addEventListener("load",g,!1)):(a.attachEvent("onload",g),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),f=c.source||{},f.concatemoji?e(f.concatemoji):f.wpemoji&&f.twemoji&&(e(f.twemoji),e(f.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='ultimate-tables-style-css'  href='http://www.wgca.org/wp-content/plugins/ultimate-tables/css/ultimate-tables.css' type='text/css' media='all' />
<link rel='stylesheet' id='ultimate-datatables-style-css'  href='http://www.wgca.org/wp-content/plugins/ultimate-tables/css/jquery.dataTables.css' type='text/css' media='all' />
<link rel='stylesheet' id='mk-style-css'  href='http://www.wgca.org/wp-content/themes/jupiter/style.css' type='text/css' media='all' />
<link rel='stylesheet' id='google-font-api-special-1-css'  href='//fonts.googleapis.com/css?family=Open+Sans%3A400%2C300%2C600%2C700%2C800' type='text/css' media='all' />
<link rel='stylesheet' id='layerslider-css'  href='http://www.wgca.org/wp-content/plugins/LayerSlider/static/css/layerslider.css' type='text/css' media='all' />
<link rel='stylesheet' id='ls-google-fonts-css'  href='http://fonts.googleapis.com/css?family=Lato:100,300,regular,700,900%7COpen+Sans:300%7CIndie+Flower:regular%7COswald:300,regular,700&#038;subset=latin%2Clatin-ext' type='text/css' media='all' />
<link rel='stylesheet' id='contact-form-7-css'  href='http://www.wgca.org/wp-content/plugins/contact-form-7/includes/css/styles.css' type='text/css' media='all' />
<link rel='stylesheet' id='gglcptch-css'  href='http://www.wgca.org/wp-content/plugins/google-captcha/css/gglcptch.css' type='text/css' media='all' />
<link rel='stylesheet' id='rs-settings-css'  href='http://www.wgca.org/wp-content/plugins/revslider/rs-plugin/css/settings.css?rev=4.0.2' type='text/css' media='all' />
<link rel='stylesheet' id='rs-captions-css'  href='http://www.wgca.org/wp-content/plugins/revslider/rs-plugin/css/dynamic-captions.css?rev=4.0.2' type='text/css' media='all' />
<link rel='stylesheet' id='rs-plugin-static-css'  href='http://www.wgca.org/wp-content/plugins/revslider/rs-plugin/css/static-captions.css?rev=4.0.2' type='text/css' media='all' />
<link rel='stylesheet' id='wprssmi_template_styles-css'  href='http://www.wgca.org/wp-content/plugins/wp-rss-multi-importer/templates/templates.css' type='text/css' media='all' />
<link rel='stylesheet' id='widget-this-week-pro-style-css'  href='http://www.wgca.org/wp-content/plugins/events-calendar-pro/src/resources/css/widget-this-week-full.css' type='text/css' media='all' />
<link rel='stylesheet' id='tribe_events-widget-this-week-pro-style-css'  href='http://www.wgca.org/wp-content/plugins/events-calendar-pro/src/resources/css/widget-this-week-theme.min.css' type='text/css' media='all' />
<link rel='stylesheet' id='wpmu-wpmu-ui-3-min-css-css'  href='http://www.wgca.org/wp-content/plugins/wordpress-popup/inc/external/wpmu-lib/css/wpmu-ui.3.min.css' type='text/css' media='all' />
<link rel='stylesheet' id='wpmu-animate-3-min-css-css'  href='http://www.wgca.org/wp-content/plugins/wordpress-popup/inc/external/wpmu-lib/css/animate.3.min.css' type='text/css' media='all' />
<!-- This site uses the Google Analytics by Yoast plugin v5.4.6 - Universal disabled - https://yoast.com/wordpress/plugins/google-analytics/ -->
<script type="text/javascript">

	var _gaq = _gaq || [];
	_gaq.push(['_setAccount', 'UA-39601708-1']);
	_gaq.push(['_gat._forceSSL']);
	_gaq.push(['_trackPageview']);

	(function () {
		var ga = document.createElement('script');
		ga.type = 'text/javascript';
		ga.async = true;
		ga.src = ('https:' == document.location.protocol ? 'https://ssl' : 'http://www') + '.google-analytics.com/ga.js';
		var s = document.getElementsByTagName('script')[0];
		s.parentNode.insertBefore(ga, s);
	})();

</script>
<!-- / Google Analytics by Yoast -->
<script type='text/javascript' src='http://www.wgca.org/wp-includes/js/jquery/jquery.js'></script>
<script type='text/javascript' src='http://www.wgca.org/wp-includes/js/jquery/jquery-migrate.min.js'></script>
<script type='text/javascript' src='http://www.wgca.org/wp-content/plugins/LayerSlider/static/js/greensock.js'></script>
<script type='text/javascript' src='http://www.wgca.org/wp-content/plugins/LayerSlider/static/js/layerslider.kreaturamedia.jquery.js'></script>
<script type='text/javascript' src='http://www.wgca.org/wp-content/plugins/LayerSlider/static/js/layerslider.transitions.js'></script>
<script type='text/javascript' src='http://www.wgca.org/wp-content/plugins/itro-popup/scripts/itro-scripts.js'></script>
<script type='text/javascript' src='http://www.wgca.org/wp-content/plugins/popup-builder/javascript/sg_popup_core.js'></script>
<script type='text/javascript' src='http://www.wgca.org/wp-content/plugins/revslider/rs-plugin/js/jquery.themepunch.plugins.min.js?rev=4.0.2'></script>
<script type='text/javascript' src='http://www.wgca.org/wp-content/plugins/revslider/rs-plugin/js/jquery.themepunch.revolution.min.js?rev=4.0.2'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var tribe_this_week = {"ajaxurl":"http:\/\/www.wgca.org\/wp-admin\/admin-ajax.php"};
/* ]]> */
</script>
<script type='text/javascript' src='http://www.wgca.org/wp-content/plugins/events-calendar-pro/src/resources/js/widget-this-week.min.js'></script>
<link rel='https://api.w.org/' href='http://www.wgca.org/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="http://www.wgca.org/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="http://www.wgca.org/wp-includes/wlwmanifest.xml" /> 
<link rel='prev' title='Just Because You Don&#8217;t See Tears&#8230;Doesn&#8217;t Mean Their Heart Isn&#8217;t Crying' href='http://www.wgca.org/blog/just-because-you-dont-see-tears-doesnt-mean-their-heart-isnt-crying/' />
<meta name="generator" content="WordPress 4.4.7" />
<link rel="canonical" href="http://www.wgca.org/blog/im-going-to-fight-for-you/" />
<link rel='shortlink' href='http://www.wgca.org/?p=14436' />
<link rel="alternate" type="application/json+oembed" href="http://www.wgca.org/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fwww.wgca.org%2Fblog%2Fim-going-to-fight-for-you%2F" />
<link rel="alternate" type="text/xml+oembed" href="http://www.wgca.org/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fwww.wgca.org%2Fblog%2Fim-going-to-fight-for-you%2F&#038;format=xml" />
<script type="text/javascript">var ajaxurl = "http://www.wgca.org/wp-admin/admin-ajax.php"</script>		<style type="text/css">.recentcomments a{display:inline !important;padding:0 !important;margin:0 !important;}</style>
		
<link rel="stylesheet" href="http://www.wgca.org/wp-content/plugins/wassup/css/wassup-widget.css?ver=1.9" type="text/css" />
<script type="text/javascript">
//<![CDATA[
	var screen_res=screen.width+" x "+screen.height;
	if(screen_res==" x ") screen_res=window.screen.width+" x "+window.screen.height;
	if(screen_res==" x ") screen_res=screen.availWidth+" x "+screen.availHeight;
	if(screen_res!=" x "){document.cookie = "wassup_screen_res9ab38a8b7f118e48892418ae7a71e482=" + encodeURIComponent(screen_res)+ "; path=/; domain=";}
//]]>
</script><meta property="og:image" content="http://www.wgca.org/wp-includes/images/media/default.png"/>
<meta property="og:url" content="http://www.wgca.org/blog/im-going-to-fight-for-you/"/>
<meta property="og:title" content="I&#8217;m Going To Fight For You"/>
    <style type="text/css">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</style> 
    </head>

<body class="single single-post postid-14436 single-format-standard  mk-boxed-enabled mk-background-stretch main-nav-align-center tribe-theme-jupiter tribe-bar-is-disabled">

<div id="mk-boxed-layout">
<header id="mk-header" data-height="108" data-sticky-height="55" class="modern-style-nav mk-background-stretch mk-video-holder">
  
<div class="mk-header-toolbar">
    <nav id="mk-toolbar-navigation" class="mk_toolbar_menu"><ul id="menu-header-toolbar" class="menu"><li id="menu-item-8194" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-8194"><a href="http://www.wgca.org/contact-us/">Contact Us</a></li>
<li id="menu-item-8195" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-8195"><a href="http://www.wgca.org/qa/">FAQ&#8217;s</a></li>
<li id="menu-item-8696" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-8696"><a href="http://www.wgca.org/blog-2/">Blog</a></li>
</ul></nav>
    <span class="header-toolbar-contact"><i class="mk-icon-phone-sign"></i>(217) 224-9422</span><span class="header-toolbar-contact"><i class="mk-icon-envelope-alt"></i><a href="mailto:&#116;&#104;&#101;m&#105;&#120;&#64;&#119;&#103;&#99;a.&#111;&#114;&#103;">th&#101;m&#105;x&#64;w&#103;c&#97;&#46;&#111;&#114;&#103;</a></span>
    <span class="mk-header-tagline">88.5fm WGCA: THE MIX!</span>
    
    
    	<div id="mk-header-search">
      <form class="mk-header-searchform" method="get" id="mk-header-searchform" action="http://www.wgca.org">
        <span>
        <input type="text" class="text-input on-close-state" value="" name="s" id="s" placeholder="Search.." />
        <i class="mk-icon-search"><input value="" type="submit" class="header-search-btn" /></i>
        </span>
    </form>
    </div>
	    <div id="mk-header-social"><ul><li><a class="facebook-hover" target="_blank" href="https://www.facebook.com/pages/WGCA-885-FM-THE-MIX/303297867173?ref=nf"><i class="mk-jupiter-icon-facebook" alt="facebook" title="facebook"></i></a></li><li><a class="pinterest-hover" target="_blank" href="http://www.pinterest.com/wgca/"><i class="mk-jupiter-icon-pinterest" alt="pinterest" title="pinterest"></i></a></li><li><a class="apple-hover" target="_blank" href="https://itunes.apple.com/us/app/wgca-88.5-fm/id688815324?mt=8"><i class="mk-jupiter-icon-apple" alt="apple" title="apple"></i></a></li><li><a class="google-hover" target="_blank" href="https://play.google.com/store/apps/details?id=com.onseeker.wgca885fm"><i class="mk-jupiter-icon-google" alt="google" title="google"></i></a></li><li><a class="twitter-hover" target="_blank" href="https://twitter.com/WGCATheMix"><i class="mk-jupiter-icon-twitter" alt="twitter" title="twitter"></i></a></li><li><a class="youtube-hover" target="_blank" href="https://www.youtube.com/channel/UC7JX1pgUwE9_0SYrtgeubug"><i class="mk-jupiter-icon-youtube" alt="youtube" title="youtube"></i></a></li></ul><div class="clearboth"></div></div>
             	<div class="mk-header-login">
    <a href="#" id="mk-header-login-button" class="mk-login-link mk-toggle-trigger"><i class="mk-icon-user"></i>Login</a>
	<div class="mk-login-register mk-box-to-trigger">

		<div id="mk-login-panel">
				<form id="mk_login_form" name="mk_login_form" method="post" class="mk-login-form" action="http://www.wgca.org/wp-login.php">
					<span class="form-section">
					<label for="log">Username</label>
					<input type="text" id="username" name="log" class="text-input">
					</span>
					<span class="form-section">
						<label for="pwd">Password</label>
						<input type="password" id="password" name="pwd" class="text-input">
					</span>
										<label class="mk-login-remember">
						<input type="checkbox" name="rememberme" id="rememberme" value="forever"> Remember Me					</label>

					<input type="submit" id="login" name="submit_button" class="shop-flat-btn shop-skin-btn" value="LOG IN">
					<input type="hidden" value="login" class="" name="mk_form_action">
					<input type="hidden" value="mk_do_action" class="" name="action">
					<input type="hidden" value="http://www.wgca.org/blog/im-going-to-fight-for-you" class="mk_login_redirect" name="submit">
					<div class="register-login-links">
							<a href="#" class="mk-forget-password">Forget?</a>
													<a href="#" class="mk-create-account">Register</a>
											</div>
				</form>
		</div>

					<div id="mk-register-panel">
					<div class="mk-login-title">Create Account</div>

					<form id="register_form" name="login_form" method="post" class="mk-form-regsiter" action="http://www.wgca.org/wp-login.php?action=register">
						<span class="form-section">
							<label for="log">Username</label>
							<input type="text" id="reg-username" name="user_login" class="text-input">
						</span>
						<span class="form-section">
							<label for="user_email">Your email</label>
							<input type="text" id="reg-email" name="user_email" class="text-input">
						</span>
						<span class="form-section">
							<label for="user_password">Your password</label>
							<input type="text" id="reg-pass" name="user_password" class="text-input">
						</span>
						<span class="form-section">
							<label for="user_password2">Verify password</label>
							<input type="text" id="reg-pass" name="user_password2" class="text-input">
						</span>
						<span class="form-section">
							<input type="submit" id="signup" name="submit" class="shop-flat-btn shop-skin-btn" value="Create Account">
						</span>
								<style type="text/css" media="screen">
			#loginform,
			#lostpasswordform,
			#registerform {
				width: 320px !important;
			}
			#login_error,
			.message {
				width: 340px !important;
			}
			#loginform .gglcptch,
			#lostpasswordform .gglcptch,
			#registerform .gglcptch {
				margin-bottom: 10px;
			}
		</style>
		<div class="gglcptch gglcptch_v1"><div id="gglcptch_recaptcha_1" class="gglcptch_recaptcha"></div><noscript>
        <iframe src="http://www.google.com/recaptcha/api/noscript?k=6LfYFAkUAAAAAI-MMSRqq5heVfMWIOO5c7qCqbFQ" height="300" width="320" frameborder="0"></iframe><br/>
        <textarea name="recaptcha_challenge_field" rows="3" cols="40" style="width: 320px !important; border: 1px solid #333 !important; resize: none !important;"></textarea>
        <input type="hidden" name="recaptcha_response_field" value="manual_challenge"/>
        </noscript></div>						<input type="hidden" name="user-cookie" value="1" />
						<input type="hidden" name="redirect_to" value="http://www.wgca.org/blog/im-going-to-fight-for-you?register=true" />
						<div class="register-login-links">
							<a class="mk-return-login" href="#">Already have an account?</a>
						</div>
					</form>
			</div>
		
		<div id="mk-forget-panel">
				<span class="mk-login-title">Forget your password?</span>
				<form id="forgot_form" name="login_form" method="post" class="mk-forget-password-form" action="http://www.wgca.org/wp-login.php?action=lostpassword">
					<span class="form-section">
							<label for="user_login">Username or E-mail</label>
						<input type="text" id="forgot-email" name="user_login" class="text-input">
					</span>
					<span class="form-section">
						<input type="submit" id="recover" name="submit" class="shop-flat-btn shop-skin-btn" value="Get New Password">
					</span>
					<div class="register-login-links">
						<a class="mk-return-login" href="#">Remember Password?</a>
					</div>
				</form>

		</div>
	</div>
</div>
 
   
    
      <div class="clearboth"></div>
</div>
<!-- End Header Toolbae -->


<div class="mk-header-inner">
  <div class="mk-header-bg "></div>
  <div class="mk-header-right">
    
  <a href="" class="mk-header-start-tour"><a href="http://www.wgca.org/donate-2/" rel="nofollow"><img src="http://www.wgca.org/wp-content/uploads/2014/06/DonateNowPurple.png"></a><i class="mk-icon-caret-right"></i></a>    </div>
    <div data-megawidth="1140" class="mk-header-nav-container modern-style mk-mega-nav">
  <nav id="mk-main-navigation" class="main_menu"><ul id="menu-main-navigation" class="main-navigation-ul"><li id="menu-item-7308" class="menu-item menu-item-type-post_type menu-item-object-page"><a href="http://www.wgca.org/">Home</a></li>
<li id="menu-item-7632" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children"><a href="#">Community</a>
<ul class="sub-menu ">
	<li id="menu-item-8693" class="menu-item menu-item-type-post_type menu-item-object-page"><a href="http://www.wgca.org/blog-2/">Blog</a></li>
	<li id="menu-item-8420" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children"><a href="http://www.wgca.org/church-directory-3/">Church Directory</a>
	<ul class="sub-menu ">
		<li id="menu-item-8350" class="menu-item menu-item-type-post_type menu-item-object-page"><a href="http://www.wgca.org/quincy/">Quincy</a></li>
		<li id="menu-item-8354" class="menu-item menu-item-type-post_type menu-item-object-page"><a href="http://www.wgca.org/macomb/">Macomb</a></li>
		<li id="menu-item-8360" class="menu-item menu-item-type-post_type menu-item-object-page"><a href="http://www.wgca.org/other-illinois/">Other Illinois</a></li>
		<li id="menu-item-8371" class="menu-item menu-item-type-post_type menu-item-object-page"><a href="http://www.wgca.org/hannibal/">Hannibal</a></li>
		<li id="menu-item-8419" class="menu-item menu-item-type-post_type menu-item-object-page"><a href="http://www.wgca.org/other-missouri/">Other Missouri</a></li>
		<li id="menu-item-8370" class="menu-item menu-item-type-post_type menu-item-object-page"><a href="http://www.wgca.org/burlington/">Burlington</a></li>
		<li id="menu-item-8369" class="menu-item menu-item-type-post_type menu-item-object-page"><a href="http://www.wgca.org/keokuk/">Keokuk</a></li>
	</ul>
</li>
	<li id="menu-item-10632" class="menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.wgca.org/events/">Community Calendar</a></li>
	<li id="menu-item-7642" class="menu-item menu-item-type-post_type menu-item-object-page"><a href="http://www.wgca.org/our-underwriters/">Our Underwriters</a></li>
	<li id="menu-item-7631" class="menu-item menu-item-type-post_type menu-item-object-page"><a href="http://www.wgca.org/prayer-request/">Prayer Request</a></li>
</ul>
</li>
<li id="menu-item-7646" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children"><a href="#">Support</a>
<ul class="sub-menu ">
	<li id="menu-item-7660" class="menu-item menu-item-type-post_type menu-item-object-page"><a href="http://www.wgca.org/become-underwriter/">Become an Underwriter</a></li>
	<li id="menu-item-7662" class="menu-item menu-item-type-post_type menu-item-object-page"><a href="http://www.wgca.org/how-to-give/">How To Give</a></li>
	<li id="menu-item-7659" class="menu-item menu-item-type-post_type menu-item-object-page"><a href="http://www.wgca.org/mix-minute-man-program/">Mix Minute Man Program</a></li>
	<li id="menu-item-7661" class="menu-item menu-item-type-post_type menu-item-object-page"><a href="http://www.wgca.org/sharathon/">Sharathon</a></li>
</ul>
</li>
<li id="menu-item-7772" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children"><a href="#">Program</a>
<ul class="sub-menu ">
	<li id="menu-item-7781" class="menu-item menu-item-type-post_type menu-item-object-page"><a href="http://www.wgca.org/program-schedule/">Program Schedule</a></li>
	<li id="menu-item-8868" class="menu-item menu-item-type-post_type menu-item-object-page"><a href="http://www.wgca.org/video-spotlight/">Weekly Video Spotlight</a></li>
</ul>
</li>
<li id="menu-item-7670" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children"><a href="#">Events</a>
<ul class="sub-menu ">
	<li id="menu-item-7672" class="menu-item menu-item-type-post_type menu-item-object-page"><a href="http://www.wgca.org/featured-events/">Event Photos</a></li>
	<li id="menu-item-10638" class="menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.wgca.org/events/">Community Calendar</a></li>
	<li id="menu-item-10000" class="menu-item menu-item-type-taxonomy menu-item-object-category"><a href="http://www.wgca.org/category/sharathon/">Sharathon! Behind the Scenes&#8230;</a></li>
</ul>
</li>
<li id="menu-item-7695" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children"><a href="#">About Us</a>
<ul class="sub-menu ">
	<li id="menu-item-7696" class="menu-item menu-item-type-post_type menu-item-object-page"><a href="http://www.wgca.org/contact-us/">Contact Us</a></li>
	<li id="menu-item-7698" class="menu-item menu-item-type-post_type menu-item-object-page"><a href="http://www.wgca.org/contest-rules/">Contest Rules</a></li>
	<li id="menu-item-7699" class="menu-item menu-item-type-post_type menu-item-object-page"><a href="http://www.wgca.org/qa/">FAQ&#8217;s</a></li>
	<li id="menu-item-7773" class="menu-item menu-item-type-post_type menu-item-object-page"><a href="http://www.wgca.org/meet-the-crew/">Meet the Crew</a></li>
	<li id="menu-item-10871" class="menu-item menu-item-type-post_type menu-item-object-page"><a href="http://www.wgca.org/employment/">Join the Crew</a></li>
	<li id="menu-item-7700" class="menu-item menu-item-type-post_type menu-item-object-page"><a href="http://www.wgca.org/music-and-ministry/">Music and Ministry</a></li>
	<li id="menu-item-7702" class="menu-item menu-item-type-post_type menu-item-object-page"><a href="http://www.wgca.org/our-history/">Our History</a></li>
	<li id="menu-item-7701" class="menu-item menu-item-type-post_type menu-item-object-page"><a href="http://www.wgca.org/our-mission-and-vision/">Our Mission and Vision</a></li>
	<li id="menu-item-7697" class="menu-item menu-item-type-post_type menu-item-object-page"><a href="http://www.wgca.org/privacy-policy/">Privacy Policy</a></li>
	<li id="menu-item-9999" class="menu-item menu-item-type-taxonomy menu-item-object-category"><a href="http://www.wgca.org/category/sharathon/">Sharathon! Behind the Scenes&#8230;</a></li>
</ul>
</li>
</ul></nav>     
  </div>

    <div class="mk-nav-responsive-link"><i class="mk-moon-menu-3"></i></div>
  		<div class="header-logo left-logo">
		    <a href="http://www.wgca.org/" title="WGCA 88.5fm"><img alt="WGCA 88.5fm" src="http://www.wgca.org/wp-content/uploads/2013/12/WGCA_logo1.jpg" /></a>
		</div>

		  <div class="clearboth"></div>
  <div class="clearboth"></div>
</div>
<div class="mk-header-padding-wrapper"></div>
<div class="clearboth"></div>

<div class="mk-zindex-fix">    
<section id="mk-page-introduce" class="intro-left"><div class="mk-grid"><h1 class="page-introduce-title ">I&#8217;m Going To Fight For You</h1><div id="mk-breadcrumbs"><div class="mk-breadcrumbs-inner dark-skin"><a href="http://www.wgca.org/" class="home">Home</a> <span class='separator'>/</span> <a href="http://www.wgca.org/category/blog/" title="Blog">Blog</a> <span class='separator'>/</span> I&#8217;m Going To Fight For You</div></div><div class="clearboth"></div></div></section></div>
<div class="clearboth"></div>
      <form class="responsive-searchform" method="get" style="display:none;" action="http://www.wgca.org">
        <input type="text" class="text-input" value="" name="s" id="s" placeholder="Search.." />
        <i class="mk-icon-search"><input value="" type="submit" /></i>
    </form>
	</header>

<nav class="mk-blog-pagination mk-loop-next-prev">
<a href="http://www.wgca.org/blog/just-because-you-dont-see-tears-doesnt-mean-their-heart-isnt-crying/" title="Just Because You Don&#8217;t See Tears&#8230;Doesn&#8217;t Mean Their Heart Isn&#8217;t Crying" class="mk-prev-post"><i class="mk-icon-chevron-left"></i></a></nav>

<div id="theme-page">

			

	<div class="theme-page-wrapper mk-blog-single full-layout vc_row-fluid mk-grid row-fluid">
		<div class="theme-content">
		<article id="14436" class="post-14436 post type-post status-publish format-standard hentry category-blog">

						<div class="blog-single-meta">
				<div class="mk-blog-author">By <a href="http://www.wgca.org/author/brittany-phillips/" title="Posts by Miss Bee" rel="author">Miss Bee</a></div>
					<time class="mk-post-date" datetime="February 7th, 2017">
						Posted <a href="201702">February 7th, 2017</a>
					</time>
					<div class="mk-post-cat"> In <a href="http://www.wgca.org/category/blog/" rel="category tag">Blog</a></div>
			</div>	
			
			<div class="single-social-section">

			<div class="mk-love-holder"><a href="#" class="mk-love-this " id="mk-love-14436"><i class="mk-icon-heart"></i> <span class="mk-love-count">0</span></a></div>	
			<a href="http://www.wgca.org/blog/im-going-to-fight-for-you/#comments" class="blog-modern-comment"><i class="mk-moon-bubble-9"></i><span> 0</span></a>

			<div class="blog-share-container">
			<div class="blog-single-share mk-toggle-trigger"><i class="mk-moon-share"></i></div>
			<ul class="single-share-box mk-box-to-trigger">
			<li><a class="facebook-share" data-title="I&#8217;m Going To Fight For You" data-url="http://www.wgca.org/blog/im-going-to-fight-for-you/" href="#"><i class="mk-jupiter-icon-simple-facebook"></i></a></li>
			<li><a class="twitter-share" data-title="I&#8217;m Going To Fight For You" data-url="http://www.wgca.org/blog/im-going-to-fight-for-you/" href="#"><i class="mk-jupiter-icon-simple-twitter"></i></a></li>
			<li><a class="googleplus-share" data-title="I&#8217;m Going To Fight For You" data-url="http://www.wgca.org/blog/im-going-to-fight-for-you/" href="#"><i class="mk-jupiter-icon-simple-googleplus"></i></a></li>
			<li><a class="pinterest-share" data-image="http://www.wgca.org/wp-includes/images/media/default.png" data-title="I&#8217;m Going To Fight For You" data-url="http://www.wgca.org/blog/im-going-to-fight-for-you/" href="#"><i class="mk-jupiter-icon-simple-pinterest"></i></a></li>
			</ul>
			</div>

			
			<div class="clearboth"></div>
			</div>
			<div class="clearboth"></div>
									
					
 							

							<div class="clearboth"></div>
							<div class="mk-single-content">
								<p><img class="aligncenter size-full wp-image-14437" src="http://www.wgca.org/wp-content/uploads/2017/02/Fight-For-You-Lyrics-.jpg" alt="Fight For You Lyrics" width="2560" height="947" srcset="http://www.wgca.org/wp-content/uploads/2017/02/Fight-For-You-Lyrics--300x111.jpg 300w, http://www.wgca.org/wp-content/uploads/2017/02/Fight-For-You-Lyrics--768x284.jpg 768w, http://www.wgca.org/wp-content/uploads/2017/02/Fight-For-You-Lyrics--1024x379.jpg 1024w, http://www.wgca.org/wp-content/uploads/2017/02/Fight-For-You-Lyrics-.jpg 2560w" sizes="(max-width: 2560px) 100vw, 2560px" /></p>
<p>&#8220;Fight For You” by Grayson Reed is my official Valentine’s Day song of 2017.  Interesting choice, you might say, but sometimes love isn’t all fuzzy feelings with rainbows and butterflies.</p>
<p>Love takes work.</p>
<p>The honesty and rawness of “Fight For You” is so incredibly accurate for what a marriage is all about it’s amazing.  Also, I prefer for young women and men that are preparing their hearts for marriage to not focus on unrealistic Disney fairytales but rather the truth behind this song.</p>
<p>It begins by saying “I know how to push your button” and “what to say to break you down.  I know how to give you nothing” and “to turn and shut you out.”  WHOA…harsh, right?  But so true! In marriage we get to know the other person so well we know exactly what to do or say to cut them deep.  We are completely vulnerable with our love towards our spouse and  they know every secret.   Sometimes, as humans, we make the grave mistake to use that vulnerability to harm, manipulate or coherence to get our way.   That’s simply the cold, harsh truth.</p>
<p>Then, the next part of the song leads into the hopeful chorus and sets up a great climax that clearly states that this marriage is going to be saved.  No matter what, they will honor each other.  The song says “We are everything but perfect, we both have a million flaws and there are days that I wanna give up BUT I WON’T because…”</p>
<p>“I’M GONNA FIGHT FOR YOU, NOTHING’S EVER GONNA BURN THIS DOWN.</p>
<p>I’M GONNA FIGHT FOR YOU, TILL THE BREATH IN MY LUNGS RUN OUT</p>
<p>OUR LOVE IS SOMETHING I DON’T WANNA LOSE, SO EVERY SINGLE DAY I’M GONNA CHOOSE</p>
<p>I’M GONNA FIGHT FOR YOU.”</p>
<p>That chorus is…inspiring!  I am a singer, so naturally I sing along with the song and feel like I am expressing exactly how my heart feels!  For non-singers, I pray you feel the hope in the voices and lyrics as they profess their battle cry to not give up on the love of their life.  To never leave the person God chose for them to be with and walk this journey on Earth as a team.  No way, no how this marriage is ever ending because I love YOU.  I CHOOSE YOU.  I CHOOSE US.</p>
<p>Marriage is full of choices.  I don’t know what’s happened in your marriage or your past hurts.  I won’t pretend that marriage is easy or tell you that you HAVE to let go of what’s been done.  I am not here to cast judgement or say my marriage is perfect.</p>
<p>BUT</p>
<p>I am here to encourage you to CHOOSE to work on your marriage daily.  God gave us the ability to choose and this is a choice.  He will provide every tool under the sun to help repair and spice up your marriage, you just have to take it.</p>
<p>&nbsp;</p>
<p>God is Love and Love Is God.</p>
<p>&nbsp;</p>
							</div>
							
							<div class="single-post-tags">
																	<span>Tags:</span> 
																								</div>
							<div class="single-back-top">
								<a href="#"><i class="mk-icon-chevron-up"></i>Back to Top</a>	
							</div>




										<div class="mk-about-author-wrapper">
								<div class="avatar-wrapper"><img alt='Miss Bee' src='http://1.gravatar.com/avatar/1aff37a7ea41bd0dbb33879064d8a5bf?s=65&#038;d=mm&#038;r=g' srcset='http://1.gravatar.com/avatar/1aff37a7ea41bd0dbb33879064d8a5bf?s=130&amp;d=mm&amp;r=g 2x' class='avatar avatar-65 photo' height='65' width='65' /></div>
								<div class="mk-about-author-meta">
								<a class="about-author-name" href="http://www.wgca.org/author/brittany-phillips/">Miss Bee</a>
								<div class="about-author-desc"></div>
								<ul class="about-author-social">
									<li><a class="email-icon" title="Get in touch with me via email" href="mailto:brittany.phillips@wgca.org"><i class="mk-icon-envelope-alt"></i></a></li>																											
								</ul>
								</div>
								<div class="clearboth"></div>
						</div>
											


						<section class="blog-similar-posts"><div class="similar-post-title">Recent Posts</div><ul class="four-cols"><li><div class="similar-post-holder"><a class="mk-similiar-thumbnail" href="http://www.wgca.org/blog/im-going-to-fight-for-you/" title="I&#8217;m Going To Fight For You"><img src="http://www.wgca.org/wp-content/uploads/thumb-cache/empty-thumb-06c3cad6fd1dc86234917fc8f1b84c6a-255x205-9-crop.png" alt="I&#8217;m Going To Fight For You" /></a><a href="http://www.wgca.org/blog/im-going-to-fight-for-you/" class="mk-similiar-title">I&#8217;m Going To Fight For You</a></div></li><li><div class="similar-post-holder"><a class="mk-similiar-thumbnail" href="http://www.wgca.org/blog/just-because-you-dont-see-tears-doesnt-mean-their-heart-isnt-crying/" title="Just Because You Don&#8217;t See Tears&#8230;Doesn&#8217;t Mean Their Heart Isn&#8217;t Crying"><img src="http://www.wgca.org/wp-content/uploads/thumb-cache/empty-thumb-06c3cad6fd1dc86234917fc8f1b84c6a-255x205-9-crop.png" alt="Just Because You Don&#8217;t See Tears&#8230;Doesn&#8217;t Mean Their Heart Isn&#8217;t Crying" /></a><a href="http://www.wgca.org/blog/just-because-you-dont-see-tears-doesnt-mean-their-heart-isnt-crying/" class="mk-similiar-title">Just Because You Don&#8217;t See Tears&#8230;Doesn&#8217;t Mean Their Heart Isn&#8217;t Crying</a></div></li><li><div class="similar-post-holder"><a class="mk-similiar-thumbnail" href="http://www.wgca.org/blog/let-your-life-honor-god-even-if-you-have-to-do-it-alone/" title="Let Your Life Honor God.  Even If You Have To Do It Alone."><img src="http://www.wgca.org/wp-content/uploads/thumb-cache/empty-thumb-06c3cad6fd1dc86234917fc8f1b84c6a-255x205-9-crop.png" alt="Let Your Life Honor God.  Even If You Have To Do It Alone." /></a><a href="http://www.wgca.org/blog/let-your-life-honor-god-even-if-you-have-to-do-it-alone/" class="mk-similiar-title">Let Your Life Honor God.  Even If You Have To Do It Alone.</a></div></li><li><div class="similar-post-holder"><a class="mk-similiar-thumbnail" href="http://www.wgca.org/blog/correction-is-a-blessing/" title="Correction Is A Blessing"><img src="http://www.wgca.org/wp-content/uploads/thumb-cache/empty-thumb-06c3cad6fd1dc86234917fc8f1b84c6a-255x205-9-crop.png" alt="Correction Is A Blessing" /></a><a href="http://www.wgca.org/blog/correction-is-a-blessing/" class="mk-similiar-title">Correction Is A Blessing</a></div></li></ul><div class="clearboth"></div></section>					
					
<section id="comments">

 

	<div id="respond">
		<h3 class="respond-heading">Leave a Comment</h3>

		
    	<div class="cancel-comment-reply">
        	<a rel="nofollow" id="cancel-comment-reply-link" href="/blog/im-going-to-fight-for-you/#respond" style="display:none;">Click here to cancel reply.</a>		</div>
			
   		<form class=" mk-not-logged " action="http://www.wgca.org/wp-comments-post.php" method="post" id="commentform">
   		

			<div class="comment-form-name comment-form-row">
            <input type="text" name="author" class="text_input" id="author" value="" tabindex="54" placeholder="Name (Required)"  />
			</div>

			<div class="comment-form-email comment-form-row">
    <input type="text" name="email" class="text_input" id="email" value="" tabindex="56" placeholder="Email (Required)" />
			</div>

			<div class="comment-form-website comment-form-row">
    <input type="text" name="url" class="text_input" id="url" value=""  tabindex="57" placeholder="Website" />
			</div>


	<div class="comment-textarea">
            <textarea class="textarea" name="comment" rows="8" id="comment" tabindex="58"></textarea>
     </div>


	<a class="mk-button comment-form-button three-dimension mk-skin-button medium" onclick="jQuery('#commentform').submit();return false;" tabindex="59" href="#">POST COMMENT</a>
	<a href="#" class="comments-back-top"><i class="mk-icon-chevron-up"></i>Back to Top</a>
	<div class="clearboth"></div>
	<input type='hidden' name='comment_post_ID' value='14436' id='comment_post_ID' />
<input type='hidden' name='comment_parent' id='comment_parent' value='0' />
			<p style="display: none;"><input type="hidden" id="akismet_comment_nonce" name="akismet_comment_nonce" value="d38fd93c0c" /></p><p style="display: none;"><input type="hidden" id="ak_js" name="ak_js" value="35"/></p>		</form>
	</div><!--/respond-->


</section>
	
			</article>
			<div class="clearboth"></div>
			</div>
										<div class="clearboth"></div>	
		</div>

</div>
<section id="mk-footer" class="">
<div class="footer-wrapper mk-grid">
<div class="mk-padding-wrapper">
		<div class="mk-col-2-3">
			<div class="mk-col-1-3"><section id="contact_info-2" class="widget widget_contact_info"><div class="widgettitle">WGCA-FM</div>			<ul>
				
						<li><i class="mk-icon-home"></i><span>535 Maine Suite 10 Quincy, IL 62301</span></li>			<li><i class="mk-icon-phone"></i><span>(217) 224-9422</span></li>						<li><i class="mk-icon-envelope-alt"></i><span><a href="mailto:&#116;h&#101;m&#105;x&#64;wg&#99;a.o&#114;g">&#116;h&#101;&#109;i&#120;&#64;w&#103;&#99;a.org</a></span></li>									</ul>
		</section><section id="nav_menu-7" class="widget widget_nav_menu"><div class="widgettitle">Community</div><div class="menu-community-container"><ul id="menu-community" class="menu"><li id="menu-item-8695" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-8695"><a href="http://www.wgca.org/blog-2/">Blog</a></li>
<li id="menu-item-8441" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-8441"><a href="http://www.wgca.org/church-directory-3/">Church Directory</a></li>
<li id="menu-item-8091" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-8091"><a href="http://www.wgca.org/online-community/">Online Community</a></li>
<li id="menu-item-8089" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-8089"><a href="http://www.wgca.org/our-underwriters/">Our Underwriters</a></li>
<li id="menu-item-8087" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-8087"><a href="http://www.wgca.org/prayer-request/">Prayer Request</a></li>
</ul></div></section></div>
			<div class="mk-col-1-3"><section id="nav_menu-9" class="widget widget_nav_menu"><div class="widgettitle">Program</div><div class="menu-program-container"><ul id="menu-program" class="menu"><li id="menu-item-8098" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-8098"><a href="http://www.wgca.org/program-schedule/">Program Schedule</a></li>
<li id="menu-item-8869" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-8869"><a href="http://www.wgca.org/video-spotlight/">Weekly Video Spotlight</a></li>
</ul></div></section><section id="nav_menu-12" class="widget widget_nav_menu"><div class="widgettitle">Events</div><div class="menu-events-container"><ul id="menu-events" class="menu"><li id="menu-item-10639" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-10639"><a href="http://www.wgca.org/events/">Community Calendar</a></li>
<li id="menu-item-8100" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-8100"><a href="http://www.wgca.org/featured-events/">Event Photos</a></li>
</ul></div></section></div>
			<div class="mk-col-1-3"><section id="nav_menu-11" class="widget widget_nav_menu"><div class="widgettitle">About Us</div><div class="menu-about-us-container"><ul id="menu-about-us" class="menu"><li id="menu-item-8110" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-8110"><a href="http://www.wgca.org/contact-us/">Contact Us</a></li>
<li id="menu-item-8111" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-8111"><a href="http://www.wgca.org/contest-rules/">Contest Rules</a></li>
<li id="menu-item-8109" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-8109"><a href="http://www.wgca.org/qa/">FAQ&#8217;s</a></li>
<li id="menu-item-8103" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-8103"><a href="http://www.wgca.org/meet-the-crew/">Meet the Crew</a></li>
<li id="menu-item-8108" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-8108"><a href="http://www.wgca.org/music-and-ministry/">Music and Ministry</a></li>
<li id="menu-item-8105" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-8105"><a href="http://www.wgca.org/our-history/">Our History</a></li>
<li id="menu-item-8104" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-8104"><a href="http://www.wgca.org/our-mission-and-vision/">Our Mission and Vision</a></li>
<li id="menu-item-8106" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-8106"><a href="http://www.wgca.org/privacy-policy/">Privacy Policy</a></li>
</ul></div></section></div>
		</div>
		<div class="mk-col-1-3"><section id="contact_form-2" class="widget widget_contact_form"><div class="widgettitle">Contact Us</div>
	<form class="mk-contact-form" action="http://www.wgca.org/wp-content/themes/jupiter/sendmail.php" method="post" novalidate="novalidate">
			<input type="text" placeholder="Name" required="required" id="contact_name" name="contact_name" class="text-input" value="" tabindex="550" />
			<input type="email" required="required" placeholder="Email" id="contact_email" name="contact_email" class="text-input" value="" tabindex="551"  />
			<textarea placeholder="Type your message..." required="required" id="contact_content" name="contact_content" class="textarea" tabindex="552"></textarea>
			<div class="mk-form-row-widget">
       		<button type="submit" class="mk-button mk-contact-button mk-skin-button three-dimension small" tabindex="553">Send message</button></div>
       		<i class="mk-contact-loading mk-icon-spinner mk-icon-spin"></i>
       		<i class="mk-contact-success mk-icon-ok-sign"></i>
			<input type="hidden" value="wgca@p3plcpnl008.prod.phx3.secureserver.net" name="contact_to"/>
	</form>
</section></div>
 


<div class="clearboth"></div>      
</div>
</div>
<div id="sub-footer">
	<div class="mk-grid">
				
    	<span class="mk-footer-copyright">Copyright All Rights Reserved © 2013</span>
    	<nav id="mk-footer-navigation" class="footer_menu"><ul id="menu-footer-navigation" class="menu"><li id="menu-item-8198" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-8198"><a href="http://www.wgca.org/prayer-request/">Community</a></li>
<li id="menu-item-8199" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-8199"><a href="http://www.wgca.org/how-to-give/">Support</a></li>
<li id="menu-item-8200" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-8200"><a href="http://www.wgca.org/btms/">Program</a></li>
<li id="menu-item-8201" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-8201"><a href="http://www.wgca.org/event-photo-gallery/">Events</a></li>
<li id="menu-item-8202" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-8202"><a href="http://www.wgca.org/meet-the-crew/">About Us</a></li>
<li id="menu-item-8196" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-8196"><a href="http://www.wgca.org/qa/">FAQ&#8217;s</a></li>
<li id="menu-item-8197" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-8197"><a href="http://www.wgca.org/contact-us/">Contact Us</a></li>
</ul></nav>	</div>
	<div class="clearboth"></div>

</div>

</section>






</div>
<a href="#" class="mk-go-top"><i class="mk-icon-chevron-up"></i></a>
	<div class="mk-quick-contact-wrapper">
		<a href="#" class="mk-quick-contact-link"><i class="mk-icon-envelope"></i></a>
		<div id="mk-quick-contact">
			<div class="mk-quick-contact-title">Contact Us</div>
			<p>We're not around right now. But you can send us an email and we'll get back to you, asap.</p>
			<form class="mk-contact-form" action="http://www.wgca.org/wp-content/themes/jupiter/sendmail.php" method="post" novalidate="novalidate">
				<input type="text" placeholder="Your Name" required="required" id="contact_name" name="contact_name" class="text-input" value="" tabindex="412" />
				<input type="email" required="required" placeholder="Your Email" id="contact_email" name="contact_email" class="text-input" value="" tabindex="413"  />
				<textarea placeholder="Type your message..." required="required" id="contact_content" name="contact_content" class="textarea" tabindex="414"></textarea>
	       		<div class="btn-cont"><button type="submit" class="mk-contact-button shop-flat-btn shop-skin-btn" tabindex="415">Send</button></div>
	       		<i class="mk-contact-loading mk-icon-spinner mk-icon-spin"></i>
	       		<i class="mk-contact-success mk-icon-ok-sign"></i>
				<input type="hidden" value="wgca@p3plcpnl008.prod.phx3.secureserver.net" name="contact_to"/>
			</form>
			<div class="bottom-arrow"></div>
		</div>
	</div>


	<!--
<p class="small"> WassUp 1.9 timestamp: 2017-02-09 09:44:59AM UTC (03:44AM)<br />
If above timestamp is not current time, this page is cached.</p> -->
<script>window._popup_data = {"ajaxurl":"http:\/\/www.wgca.org\/wp-admin\/admin-ajax.php","do":"get_data","ajax_data":{"orig_request_uri":"\/blog\/im-going-to-fight-for-you\/"}};</script><script type='text/javascript' src='http://www.wgca.org/wp-content/plugins/akismet/_inc/form.js'></script>
<script type='text/javascript' src='http://www.wgca.org/wp-content/plugins/ultimate-tables/js/jquery.dataTables.min.js'></script>
<script type='text/javascript' src='http://www.wgca.org/wp-content/themes/jupiter/js/jquery.prettyPhoto.js'></script>
<script type='text/javascript' src='http://www.wgca.org/wp-content/themes/jupiter/js/theme-scripts-min.js'></script>
<script type='text/javascript' src='http://www.wgca.org/wp-includes/js/comment-reply.min.js'></script>
<script type='text/javascript' src='http://www.wgca.org/wp-content/plugins/contact-form-7/includes/js/jquery.form.min.js'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var _wpcf7 = {"loaderUrl":"http:\/\/www.wgca.org\/wp-content\/plugins\/contact-form-7\/images\/ajax-loader.gif","recaptchaEmpty":"Please verify that you are not a robot.","sending":"Sending ..."};
/* ]]> */
</script>
<script type='text/javascript' src='http://www.wgca.org/wp-content/plugins/contact-form-7/includes/js/scripts.js'></script>
<script type='text/javascript' src='http://www.wgca.org/wp-content/plugins/wordpress-popup/inc/external/wpmu-lib/js/wpmu-ui.3.min.js'></script>
<script type='text/javascript' src='http://www.wgca.org/wp-content/plugins/wordpress-popup/js/public.min.js'></script>
<script type='text/javascript' src='http://www.wgca.org/wp-includes/js/wp-embed.min.js'></script>
<script type='text/javascript' src='http://www.wgca.org/wp-includes/js/jquery/ui/core.min.js'></script>
<script type='text/javascript' src='http://www.wgca.org/wp-includes/js/jquery/ui/widget.min.js'></script>
<script type='text/javascript' src='http://www.wgca.org/wp-includes/js/jquery/ui/position.min.js'></script>
<script type='text/javascript' src='http://www.wgca.org/wp-includes/js/jquery/ui/menu.min.js'></script>
<script type='text/javascript' src='http://www.wgca.org/wp-includes/js/jquery/ui/autocomplete.min.js'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var vars = [];
/* ]]> */
</script>
<script type='text/javascript' src='http://www.wgca.org/wp-content/plugins/html5-mp3-player-with-playlist/html5plus/js/html5mp3playlist-min.js'></script>
<script type='text/javascript' data-cfasync="false" async="async" defer="defer" src='//www.google.com/recaptcha/api/js/recaptcha_ajax.js'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var gglcptch = {"options":{"version":"v1","sitekey":"6LfYFAkUAAAAAI-MMSRqq5heVfMWIOO5c7qCqbFQ","theme":"red","error":"<strong>Warning:<\/strong>&nbsp;It has been found more than one reCAPTCHA in current form. In this case reCAPTCHA will not work properly. Please remove all unnecessary reCAPTCHA blocks."},"vars":{"ajaxurl":"http:\/\/www.wgca.org\/wp-admin\/admin-ajax.php","error_msg":"Error: You have entered an incorrect reCAPTCHA value.","nonce":"37974236ed","visibility":false}};
/* ]]> */
</script>
<script type='text/javascript' src='http://www.wgca.org/wp-content/plugins/google-captcha/js/script.js'></script>
<script type="text/css" id="tmpl-tribe_events_pro_customizer_css"></script><style type="text/css" id="tribe_events_pro_customizer_css"></style></body>
</html>




